Topic: ESXDOS 0.8.6 BETA5 don't work


I Have two different interfaces that runs ESXDOS: DivMMC x2 & DivMMC Enjoy!

Everything works  fine with 0.8.6 BETA4 and 48K/2A/2B/+3

With BETA5 I can boot but the SD cards aren't recognized


Re: ESXDOS 0.8.6 BETA5 don't work

Me too. SD card content is just 0.
Ï dont know, if is normal, that on POST is shown "RTC failed". Maybe because \i dont have Real Time Clock installed...


Re: ESXDOS 0.8.6 BETA5 don't work


I'm little bit confused with the last line of your post. you wrote you can boot but you also wrote esxdos cannot recognize sd card. what do you mean by "can boot"? esxdos itself need access to sd card as it reads part of system from it, so if you successfully boot, then card must be recognized.

"RTC failed" is ok, it just mean you don't have file /sys/rtc.sys on your card.


can you be more specific? What exact steps you did to upgrade from BETA4 to BETA5? Please, mention all steps which you did (even any small step you might think is not that important) to upgrade from working 086b4 to non-working 086b5.

Did you tried it with freshly formatted and prepared SD?

Are you able to take some small SD (let's say 64M-256M), zero all sectors on it, format it and put there esxdos files and test it and if it is still not working then create image of it and post zipped image for analyze? Zeroing all sectors can be done by writing big file containing only zero bytes (big = size equal to rest of free space of card) and it is there just to help zip to produce a small archive.


Re: ESXDOS 0.8.6 BETA5 don't work

I have updated from b4 to b5 without problems. Works fine on my ZX-UNO and also on a DivMMC interface.

I've heard some people have problems with the FAT cluster size. It seems re-formatting the SD card with 4k cluster size solve the problems.

For upgrade the DivMMC I've burned the new firmware with an USB programmer, then replaced the esxdos.sys file. No problems as far as I can tell.