Topic: problem with booting


Recently I've bought ZX 128 and DivMMC. But I have problem when booting whole thing.

Most of the times it won't even load ESXDOS.SYS (0.8.5). Sometimes it loads it but then fails NMI.SYS. Sometimes it loads everything. But NMI still doesn't work. And when soooomeeeetimeees it works, I am unable to load games.

I did very basic memory check (print peek 23732 + peek 23733 * 256 -> shows 65535) and previous owner said that he was able to load games from tape (didn't try that as I have just one adaptor uk->eu and I have to free plugs to modify plug for taperecorder).

What else can be wrong? Is it possible that there is something with "edge connector"/interface? Or the device itself is faulty?

Is there any way to test it without second computer? (that I hoped will be still working but is dead, few years ago I thought that it might be faulty power supply but as I have another one and it doesn't give any sing of life, I resigned).

I actually have no idea how much stuff is transferred between SD card and DivMMC and how much between DivMMC and computer.


Re: problem with booting


Have you tried a different SD card? I'm not sure what else you can try, but I'm sure Velesoft will have some tips soon...


Re: problem with booting

Not yet. SD card works fine on PC but you cannot tell whether for some odd reason it would cause some problems with DivMMC. I will try different card, thanks smile

But first, I am going to make sure edge connector is clean. As I just learned that reading from SD card depends on clock signal from ZX. I am going to post if anything new comes.