1 (edited by tvandor 2013-11-01 08:03:05)

Topic: exsDOS emulation problem

Greetings! :-)

I am new here and I have a question regarding divide plus.
I have bought a  divide plus unit yesterday and while it is being shipped,
I am experimenting with emulation to see how it would work.

I successfuly configured ZX Spin for divide and esxdos, and it boots up and
seems work properly for a 48k machine. But when I set the model to a +3,
when it boots up it enters the NMI mode immediately. This would be fine too,
but when I hit space to exit NMI mode, the screen goes black and it goes
back into NMI mode again. (The file selector appears)
I have tried hitting space several times and it does go to the +3 boot menu sometimes
but I was not able to discover how to do this on will. (It just happens "accidentally")
My question is: how can we go to the +3 boot menu?
(Is this kind of boot up to nmi mode is normal?)

Maybe this is just an emulation problem, but I am not sure 100%

Is there more emulators that can emulate the divide plus?
I have tried fuse on windows (1.1.1) but I was not able to configure it.

Thanks a lot for your help guys, can't wait my divide plus to arrive. :-)



Re: exsDOS emulation problem

Hi and welcome smile

Booting straight to the NMI menu is not normal and has not been reported, so it should be some issue with the emulator. esxDOS works the same on 48/128/+3, but you will not get the 128/+3 menu - it boots in USR0 mode (48K editor with access to 128K ram). What happens if you choose a +2 instead of a +3 ?