1

Topic: Amaurote - v1.0.tap (128k version) not loading on 0.8.9

Hello All,
I was trying to load Amaurote - v1.0.tap (from worldofspectrum.net) on my Spectrum 128k using DivMMC EnJOY! *mini* and esxdos 0.8.9, but it hangs between the loading screen and game itself. The 48k version (also downloaded from the same site) works ok.

Do you have maybe any idea what can be the problem?

Thank you, m

2

Re: Amaurote - v1.0.tap (128k version) not loading on 0.8.9

thisism wrote:

Hello All,
I was trying to load Amaurote - v1.0.tap (from worldofspectrum.net) on my Spectrum 128k using DivMMC EnJOY! *mini* and esxdos 0.8.9, but it hangs between the loading screen and game itself. The 48k version (also downloaded from the same site) works ok.

Do you have maybe any idea what can be the problem?

Thank you, m

You must use L option before load the game. Lock 128k speccy paging register is necessary in most of Ultimate games like nightshade or games like Sly Spy: Secret Agent. To unlock paging register is necessary a hard reset.

3

Re: Amaurote - v1.0.tap (128k version) not loading on 0.8.9

david_ps wrote:
thisism wrote:

Hello All,
I was trying to load Amaurote - v1.0.tap (from worldofspectrum.net) on my Spectrum 128k using DivMMC EnJOY! *mini* and esxdos 0.8.9, but it hangs between the loading screen and game itself. The 48k version (also downloaded from the same site) works ok.

Do you have maybe any idea what can be the problem?

Thank you, m

You must use L option before load the game. Lock 128k speccy paging register is necessary in most of Ultimate games like nightshade or games like Sly Spy: Secret Agent. To unlock paging register is necessary a hard reset.

Thank you for help! ;-)

4 (edited by GoodBoy 2022-11-24 20:20:10)

Re: Amaurote - v1.0.tap (128k version) not loading on 0.8.9

david_ps wrote:

Lock 128k speccy paging register.

i think that's bad advice - the game will start, but in 48k mode (no additional music and graphics)
it is probably better to rewrite the loader
or as a quick fix
before downloading the game to the emulator (model zx128)
set BreakPoint (in debugger) at 26600 and save z80 SnapShot