Topic: Harlequin 128K 2G and DivMMC EnJOY! PRO ONE

Hi All,

I have a DivMMC EnJOY! PRO ONE from ByteDelight.com that I used on a 48K and worked fine until recently where the menu screen no longer gets displayed on start up.
But just goes to a 48K screen. As having a 48K I thought yeah thats ok.

Then I go and get myself a Harlequin 128K 2G version and hoped to use the DivMMC EnJOY! PRO ONE. On start up it does the same and boots to a 48K screen.
However I have my HQ128 set to 128K and tried to load a few pure 128K games like Rod-Land and The Netherending Story but seems to reset itself back to the 48K screen.

Is there any known issues in compatibility or do I have to change a few settings in any config files etc?
How do I get the startup coming back up?

----What I see at start up----
Current version: v0.8.6-DivMMV
Detecting Devices...

sbd:  TM SA08G

Mounting drivers...
hd0: ESXDOS, FAT32, 7382M

Loading ESXDOS.SYS...
Loading RTC.SYS...
Loading NMI.SYS...

Then goes into 48K screen.. sad ?


Re: Harlequin 128K 2G and DivMMC EnJOY! PRO ONE


see https://www.dropbox.com/s/952kbb1d43f8r … c.gif?dl=0

testing environment : FUSE emulator 1.5.6, ZX Spectrum+ 128, divMMC with ESXDOS 0.8.6 for divMMC (i.e. ESXMMC.TAP has been loaded  ...)

3 (edited by ElfieUK4 2018-11-10 22:15:08)

Re: Harlequin 128K 2G and DivMMC EnJOY! PRO ONE

I did that - but when it's loaded it just resets back to the command prompt.

4 (edited by Luzie 2018-11-11 11:47:59)

Re: Harlequin 128K 2G and DivMMC EnJOY! PRO ONE

Booting to 48k prompt is normal behavior with esxDOS on a 128k machine. But you can load and run 128k programs from this 48k mode. As can be read here: https://www.bytedelight.com/?p=2945


Re: Harlequin 128K 2G and DivMMC EnJOY! PRO ONE

so the problem is probably with Harlequin - I have tested  Rod-Land with my Harlequin 128 Issue 2E + divIDE and the loading of this game ends with reset ... Testing of Harlequin's RAM paging by "ZX Spectrum Diagnostics" ends without error. Real original ZX Spectrum +2 + divIDE +  Rod-Land = no problem ...


Re: Harlequin 128K 2G and DivMMC EnJOY! PRO ONE

RodLand uses IM2 with I = #88, ISR address is #8CC2 but this address is in RAM at #88FF + #8900 addresses only, unfortunately,
so if data bus (at time of interrupt) contains different value than #FF, result will be "unwanted" ...

Here https://www.dropbox.com/s/n1j5l2q4h17puzv/IM1.png?dl=0 is output of logic analyze for IM1
Here https://www.dropbox.com/s/u178y618lekjd … 2.png?dl=0 is output of logic analyze for IM2 used in RodLand
The analyzer : BeagleBone Black + BeagleLogic + a breadboard with conversion TTL to 3,3V logic
The analyzed subject : Superfo Harlequin 128 Issue 2E

Signal "7430 pin 8" is result of equation : /(D0 * D1 * D2 * D3 * D4 * D5 * D6 * D7) => result "L" means D0 ... D7 = "H"

7 (edited by zxy 2022-07-08 07:11:54)

Re: Harlequin 128K 2G and DivMMC EnJOY! PRO ONE

Superfo recommends one of the following HW patches:

https://www.dropbox.com/s/0bbx3cvd974ls … 1.jpg?dl=0

https://www.dropbox.com/s/9rw17tpcvityr … 2.jpg?dl=0