1 (edited by bracula80 2018-12-26 16:10:50)

Topic: error when using nmi button in chicago 30 game

Hello, I realized that by using the nmi button in the game chicagos 30 when returning,it hangs up

Is it nmi.sys thing or is that determiner programs do not support the interrupt function?

I have tried this behavior in emulator and I get the same results as in real machine

Merry Christmas

2 (edited by Luzie 2018-12-27 16:07:08)

Re: error when using nmi button in chicago 30 game

Hi and Merry Christmas!

I tried on SpecEmu ( Latest Version Update v3.2 Buld 25/10/18 see here: https://www.worldofspectrum.org/forums/ … ent_948741 )
and Chicagos30.tap / CHICAGO.TAP from http://www.worldofspectrum.org/infoseek … loadpics=1
on emulated Spectrum 128k with esxDOS UNLOCKED 128k / v0.8.6-DivIDE 32k and with "New NMI.SYS" v0.0.16
( New NMI.SYS: http://board.esxdos.org/viewtopic.php?pid=1012#p1012 )
and have most times NO problems with sending a NMI and e.g. save the game to a snapshot.
(On first try this may also reset the spectrum, but after loading in the .TAP and starting the game, next time NMI.SYS works. I also testet yet in esxDOS included "Old NMI.SYS" and this seems to be a litlle less stable than the "New NMI.SYS").