1 (edited by Xalior 2018-05-25 10:32:52)

Topic: .128 command crash

I'm not sure if this is just me or not but I've been getting a lot of crashes with the resultant environment after using the new .128 command under ESXDOS0.8.6 final.

I've tried lots of different things, and get lots of random crashes or corruptions. This one, however, seems pretty consistant for me.

First, my setup:

+3 Issue 1, v1.43 +3e ROMS for divMMC, DivMMC EnJOY! PRO ONE. hd0: is ESXDOS, hd1: is +3DOS -- I've tried with and without various other items attached (TK-Pie, external FDD, etc.) all to the same result.

Now, to reproduce the crash:

Boot Spectrum normally

Type ".128"
Hit Enter
Navigate to "Calculator"
Hit Enter
Type "128-48"
Hit Enter

Watch the crash....

Can anyone else reproduce this? If you can, what's your setup, please?

-Dx

2 (edited by Xalior 2018-05-25 10:36:25)

Re: .128 command crash

Oh... Additional...

Post crash, if you crash. After a soft-reset (red button on divMMC, or side trigger on +3)

Does your NMI still work?  (Mine doesn't)
Does ".ls" work in USR0? (Mine doesn't)
-Dx

3

Re: .128 command crash

Xalior wrote:

I'm not sure if this is just me or not but I've been getting a lot of crashes with the resultant environment after using the new .128 command under ESXDOS0.8.6 final.

If you use the original editor eventually you will trigger a TR-DOS trap and it will crash. The solution is to use a version of the 128 editor that never accidentally triggers the traps: https://zx.itch.io/derbyplusplus